ホーム >  WordPress >  Jetpackのパブリサイズでエラーが発生


Posted:2015/07/17 9:00:38 AM|Category : WordPress

Jetpackのパブリサイズでエラーが発生

jp0006

jetpackは非常に便利な機能が豊富です。
しかし、時折不具合が発生します。
今回はトラブルは、jetpackでの共有設定でfacebookなどと連携が取れなくなりました。
ただし、これは私のケースの場合です。
他の原因で連携できない場合もあると思いますので、ご参考までに。

私の環境

WordPress 4.2.2
レンタルサーバー X Server
jetpack バージョン: 3.6

前回のエラー現象

前回は、OGPが重複することによるエラーでした。
function.phpの記述で解決しました。
OGPを記述したらJetPackがfacebookへ自動投稿しない不具合

今回のエラー現象

共有設定のページから、facebookと「連携」ボタンを押します。
すると、以下のメッセージが表示されます。
エラーコード: -32300

他のプラグインとの競合が原因とにらみました。
しかし、プラグインを停止しても解決できませんでした。

原因

調べてみると、XML-RPCのエラーのようです。

対処方法

①Xサーバーにログインし、サーバーパネルを開きます。

②WordPressセキュリティ設定を開きます。
「ダッシュボード アクセス制限」と、「XML-RPC API アクセス制限」をオフにしましょう。

jp0007

③WordPressのダッシュボードを開きます。
jetpackの共有設定で再び「連携」ボタンをクリックすると正常に動きます。

jp0006

④②のWordPressセキュリティ設定を元のONに戻して完了です。


トラックバック用のURL
プロフィール

名前:イワサキ ユウタ 職業:システムエンジニア、ウェブマスター 誕生:1986年生まれ 出身:静岡県 特技:ウッドベース 略歴 2008年04月 金融機関系I

最近の投稿
人気記事
カテゴリー
広告